aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorBuchan Milne <buchan@mageia.org>2010-10-28 10:40:56 +0000
committerBuchan Milne <buchan@mageia.org>2010-10-28 10:40:56 +0000
commit45f7611e07bdf606b93040b2a075fd72759d44e0 (patch)
tree511fea40d574e9fcfbd2bd7109a2440dac8e2c1a /Makefile.PL
parent601b41083cf7c2186ecce70ec07aebdb9310edd6 (diff)
downloadidentity-45f7611e07bdf606b93040b2a075fd72759d44e0.tar
identity-45f7611e07bdf606b93040b2a075fd72759d44e0.tar.gz
identity-45f7611e07bdf606b93040b2a075fd72759d44e0.tar.bz2
identity-45f7611e07bdf606b93040b2a075fd72759d44e0.tar.xz
identity-45f7611e07bdf606b93040b2a075fd72759d44e0.zip
Dont run in debug mode by default (use -d option if you want debug mode)
Cleanups from Guillaume Rousse Remove some debugging
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 7a4561c..c965166 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -12,8 +12,20 @@ all_from 'lib/CatDap.pm';
requires 'Catalyst::Runtime' => '5.80022';
requires 'Catalyst::Plugin::ConfigLoader';
requires 'Catalyst::Plugin::Static::Simple';
+requires 'Catalyst::Plugin::I18N';
+requires 'Catalyst::Plugin::Authentication';
+requires 'Catalyst::Plugin::Authentication::Store::LDAP';
+requires 'Catalyst::Plugin::Captcha';
+requires 'Catalyst::Plugin::Session::Store::File';
+requires 'Catalyst::Plugin::Session::State::Cookie';
requires 'Catalyst::Action::RenderView';
+requires 'Catalyst::View::TT';
+requires 'Catalyst::View::Email';
+requires 'Catalyst::Model::LDAP::FromAuthentication';
requires 'Moose';
+requires 'Crypt::CBC';
+requires 'Email::Valid';
+requires 'Data::UUID';
requires 'namespace::autoclean';
requires 'Config::General'; # This should reflect the config file format you've chosen
# See Catalyst::Plugin::ConfigLoader for supported formats