aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorBuchan Milne <buchan@mageia.org>2010-10-26 14:51:48 +0000
committerBuchan Milne <buchan@mageia.org>2010-10-26 14:51:48 +0000
commit601b41083cf7c2186ecce70ec07aebdb9310edd6 (patch)
tree23d14b17ec560316d94f0d840f47a4ae48e9d7b3 /Makefile.PL
parent195308dcc10a015aaae5fd1f1bd0be817c2127bd (diff)
downloadidentity-601b41083cf7c2186ecce70ec07aebdb9310edd6.tar
identity-601b41083cf7c2186ecce70ec07aebdb9310edd6.tar.gz
identity-601b41083cf7c2186ecce70ec07aebdb9310edd6.tar.bz2
identity-601b41083cf7c2186ecce70ec07aebdb9310edd6.tar.xz
identity-601b41083cf7c2186ecce70ec07aebdb9310edd6.zip
Clean up repo
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..7a4561c
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,25 @@
+#!/usr/bin/env perl
+# IMPORTANT: if you delete this file your app will not work as
+# expected. You have been warned.
+use inc::Module::Install;
+use Module::Install::Catalyst; # Complain loudly if you don't have
+ # Catalyst::Devel installed or haven't said
+ # 'make dist' to create a standalone tarball.
+
+name 'CatDap';
+all_from 'lib/CatDap.pm';
+
+requires 'Catalyst::Runtime' => '5.80022';
+requires 'Catalyst::Plugin::ConfigLoader';
+requires 'Catalyst::Plugin::Static::Simple';
+requires 'Catalyst::Action::RenderView';
+requires 'Moose';
+requires 'namespace::autoclean';
+requires 'Config::General'; # This should reflect the config file format you've chosen
+ # See Catalyst::Plugin::ConfigLoader for supported formats
+test_requires 'Test::More' => '0.88';
+catalyst;
+
+install_script glob('script/*.pl');
+auto_install;
+WriteAll;