aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorPer Øyvind Karlsen <peroyvind@mandriva.org>2008-03-01 12:33:17 +0000
committerPer Øyvind Karlsen <peroyvind@mandriva.org>2008-03-01 12:33:17 +0000
commit6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5 (patch)
tree4c44858e3d976af0b741ac7b67961fa4bf65ecc8 /Makefile.PL
parenta2290efbb395b35330377e0a9acef9b92dab9aeb (diff)
downloadperl-URPM-6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5.tar
perl-URPM-6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5.tar.gz
perl-URPM-6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5.tar.bz2
perl-URPM-6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5.tar.xz
perl-URPM-6c14a9b66694bc2ef9d6a61bdf98b3ed02659fe5.zip
define WITH_DB in rpm5compat.h in stead of in Makefile
drop useless conditionals for headers as they're already conditional in themself ;)
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 6ab4b17..f760e93 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -60,7 +60,7 @@ if ($pversion ge v4.4.90 && $pversion lt v4.5) {
push @rpmflags, '-DRPM_450';
}
if ($pversion ge v5.0) {
- push @rpmflags, '-DRPM_500 -DWITH_DB';
+ push @rpmflags, '-DRPM_500';
}
}
my $ccflags = join(' ', '-Wall -fno-strict-aliasing', @rpmflags);