summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Balcaen <mikala@mageia.org>2011-03-31 12:40:05 +0000
committerJohn Balcaen <mikala@mageia.org>2011-03-31 12:40:05 +0000
commit7f6edacd73eca28b99a8c3c62936367358fed8a1 (patch)
tree18a4f9471f18b72d940c796200495f658f5839a4 /CMakeLists.txt
parent1e3467723475da8508b4ec092de58ab3f00bcf2a (diff)
downloadsplash-7f6edacd73eca28b99a8c3c62936367358fed8a1.tar
splash-7f6edacd73eca28b99a8c3c62936367358fed8a1.tar.gz
splash-7f6edacd73eca28b99a8c3c62936367358fed8a1.tar.bz2
splash-7f6edacd73eca28b99a8c3c62936367358fed8a1.tar.xz
splash-7f6edacd73eca28b99a8c3c62936367358fed8a1.zip
- Install the .desktop files too
- Rename the .pot file to kde4-splash-mga - Add missing Language & Language Team in pt.po (fix warning in po compilation)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90b163f..5970648 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,4 +24,9 @@ add_executable(kde4-splash-mga MACOSX_BUNDLE ${kde4-splash-mga_SRCS} ${kde4-spla
target_link_libraries(kde4-splash-mga ${QT_LIBRARIES} ${KDE4_KDEUI_LIBS})
-install(TARGETS kde4-splash-mga DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+##################### install files ##################################
+
+install(TARGETS kde4-splash-mga DESTINATION ${BIN_INSTALL_DIR})
+install( FILES kde4-splash-mga.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES ksplashplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+