summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Lécureuil <nlecureuil@mandriva.com>2009-05-14 19:27:25 +0000
committerNicolas Lécureuil <nlecureuil@mandriva.com>2009-05-14 19:27:25 +0000
commit3f7a8b63cb4105d4ac64b5564afdcb6f00620453 (patch)
tree352c96e0b3a798275a69da50508353253077c5f0 /CMakeLists.txt
downloadsplash-3f7a8b63cb4105d4ac64b5564afdcb6f00620453.tar
splash-3f7a8b63cb4105d4ac64b5564afdcb6f00620453.tar.gz
splash-3f7a8b63cb4105d4ac64b5564afdcb6f00620453.tar.bz2
splash-3f7a8b63cb4105d4ac64b5564afdcb6f00620453.tar.xz
splash-3f7a8b63cb4105d4ac64b5564afdcb6f00620453.zip
Branch for 2009.1 and handle trunk
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2afe582
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,27 @@
+project(kde4-splash-mdv)
+cmake_minimum_required(VERSION 2.6)
+cmake_policy(SET CMP0005 NEW)
+
+set(kde4-splash-mdv_SRCS main.cpp mainwidget.cpp themesettings.cpp imageloader.cpp animateditem.cpp application.cpp animatedstatus.cpp)
+
+find_package(KDE4 REQUIRED)
+find_package(Qt4)
+
+set(QT_USE_QTSVG 1)
+
+include(KDE4Defaults)
+include(MacroLibrary)
+include(${QT_USE_FILE})
+
+add_subdirectory(po)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${QT_INCLUDE_DIRS} ${KDE4_INCLUDES})
+add_definitions(${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+
+QT4_WRAP_CPP(kde4-splash-mdv_MOC_SRCS mainwidget.h animateditem.h application.h animatedstatus.h)
+
+add_executable(kde4-splash-mdv MACOSX_BUNDLE ${kde4-splash-mdv_SRCS} ${kde4-splash-mdv_MOC_SRCS})
+
+target_link_libraries(kde4-splash-mdv ${QT_LIBRARIES} ${KDE4_KDEUI_LIBS})
+
+install(TARGETS kde4-splash-mdv DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)