aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Hasenack <andreas@mandriva.com>2006-02-02 18:37:42 +0000
committerAndreas Hasenack <andreas@mandriva.com>2006-02-02 18:37:42 +0000
commit8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77 (patch)
treea3ffa4b776337f2f99531c75553803356a31e0d7 /setup.py
parent6bf0978af43f267fc17ce6e5d64e2053e60dae5f (diff)
downloadmgarepo-8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77.tar
mgarepo-8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77.tar.gz
mgarepo-8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77.tar.bz2
mgarepo-8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77.tar.xz
mgarepo-8d41f3bf00a47e930b3dc92d5b28a8a3a5126c77.zip
- on behalf of bogdano@mandriva.com:
- improved markrelease command line parsing - changelogs entries are now groupped by author, and sorted by revision number - the changelog now is generated using the Cheetah Template Engine, to allow quick modifications without spending time reading code and introducing new bugs - consequently, was added an option "-T <file>" to rpmlog and getsrpm to allow choosing the path of the template to be used - added options noauth=0, and baseurl=None in order to disable the authentication in some url schemes (http:// and //) - replaced some "cl" references to "mdv"
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2ff3507..84144ed 100755
--- a/setup.py
+++ b/setup.py
@@ -19,5 +19,7 @@ setup(name="repsys",
license = "GPL",
long_description = """Tools for Mandriva Linux repository access and management.""",
packages = ["RepSys", "RepSys.cgi", "RepSys.commands"],
- scripts = ["repsys"]
+ scripts = ["repsys"],
+ data_files = (
+ ("/usr/share/repsys/", ["default.chlog", "revno.chlog"]))
)