aboutsummaryrefslogtreecommitdiffstats
path: root/bootsplash.spec
diff options
context:
space:
mode:
Diffstat (limited to 'bootsplash.spec')
-rw-r--r--bootsplash.spec44
1 files changed, 44 insertions, 0 deletions
diff --git a/bootsplash.spec b/bootsplash.spec
index 0692ca0..c0b9125 100644
--- a/bootsplash.spec
+++ b/bootsplash.spec
@@ -1,6 +1,12 @@
%define name bootsplash
+<<<<<<< bootsplash.spec
+%define version 1.3.7
+%define release 1mdk
+%define _bootdir /boot
+=======
%define version 1.3.6
%define release 2mdk
+>>>>>>> 1.24
Summary: The Boot Splash Images and scripts
Name: %{name}
@@ -17,6 +23,8 @@ Requires: /usr/bin/perl
Requires: mkinitrd > 3.1.6-25mdk
#there is no way to say a special kernel requires.
Requires: kernel
+Obsoletes: Aurora Aurora-Monitor-NewStyle-Categorizing-WsLib Aurora-Monitor-NewStyle-WsLib Aurora-Monitor-Traditional-Gtk+ Aurora-Monitor-Traditional-WsLib-8.2
+
# nomore noarch with the fbrelolution and progress binaries
#BuildArchitectures: noarch
@@ -39,6 +47,37 @@ cd ..
rm -rf $RPM_BUILD_ROOT
make install prefix=$RPM_BUILD_ROOT
+%post
+cd %{_bootdir}
+ if [[ -x /usr/share/loader/make-initrd ]]; then
+ /usr/share/loader/make-initrd -n &> /dev/null
+ if [[ -x /usr/sbin/detectloader ]]; then
+ LOADER=$(/usr/sbin/detectloader -q)
+ if [[ $LOADER = "LILO" ]] && [[ -x /sbin/lilo ]];then
+ /sbin/lilo >/dev/null 2>/dev/null
+ fi
+ if [[ $LOADER = "YABOOT" ]] && [[ -x /sbin/ybin ]];then
+ /sbin/ybin >/dev/null 2>/dev/null
+ fi
+ fi
+ fi
+
+%postun
+cd %{_bootdir}
+ if [[ -x /usr/share/loader/make-initrd ]]; then
+ /usr/share/loader/make-initrd -n &> /dev/null
+ if [[ -x /usr/sbin/detectloader ]]; then
+ LOADER=$(/usr/sbin/detectloader -q)
+ if [[ $LOADER = "LILO" ]] && [[ -x /sbin/lilo ]];then
+ /sbin/lilo >/dev/null 2>/dev/null
+ fi
+ if [[ $LOADER = "YABOOT" ]] && [[ -x /sbin/ybin ]];then
+ /sbin/ybin >/dev/null 2>/dev/null
+ fi
+ fi
+ fi
+
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -51,6 +90,11 @@ rm -rf $RPM_BUILD_ROOT
/bin/*
%changelog
+* Thu Mar 07 2002 Warly <warly@mandrakesoft.com> 1.3.7-1mdk
+- obsolete Aurora
+- new images
+- update initrd (or try to)
+
* Wed Mar 06 2002 David BAUDENS <baudens@mandrakesoft.com> 1.3.6-2mdk
- Remove non Mandrake's theme