aboutsummaryrefslogtreecommitdiffstats
path: root/bootsplash.spec
diff options
context:
space:
mode:
Diffstat (limited to 'bootsplash.spec')
-rw-r--r--bootsplash.spec24
1 files changed, 20 insertions, 4 deletions
diff --git a/bootsplash.spec b/bootsplash.spec
index fde7d3c..69b720e 100644
--- a/bootsplash.spec
+++ b/bootsplash.spec
@@ -1,6 +1,6 @@
%define name bootsplash
-%define version 2.0.0
-%define release 2mdk
+%define version 2.0.1
+%define release 1mdk
%define _bootdir /boot
Summary: The Boot Splash Images and scripts
@@ -48,6 +48,8 @@ done
#find $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/ $RPM_BUILD_ROOT/%_datadir/%{name}/ -not -path "*/themes/Mandrake/*" -not -path "*/scripts/*" -type f |
# sed -e "s#^$RPM_BUILD_ROOT##g" > rpm-themes-files
+%find_lang bootsplash
+
%post
cd %{_bootdir}
if [[ -x /usr/share/loader/make-initrd ]]; then
@@ -63,6 +65,17 @@ cd %{_bootdir}
fi
fi
+# Add right translation file
+for i in `echo $LANGUAGE:$LC_ALL:$LC_COLLATE:$LANG:C | tr ':' ' '`
+do
+ if [ -r %{_datadir}/locale/$i/LC_MESSAGES/bootsplash.mo ]; then
+ mkdir -p /etc/locale/$i/LC_MESSAGES/
+ cp %{_datadir}/locale/$i/LC_MESSAGES/bootsplash.mo \
+ /etc/locale/$i/LC_MESSAGES/
+ break
+ fi
+done
+
%postun
cd %{_bootdir}
if [[ -x /usr/share/loader/make-initrd ]]; then
@@ -81,8 +94,7 @@ cd %{_bootdir}
%clean
rm -rf $RPM_BUILD_ROOT
-
-%files
+%files -f %name.lang
%defattr(-,root,root)
%doc README ChangeLog fbmngplay/ChangeLog.fbmngplay fbmngplay/README.fbmngplay fbtruetype/ChangeLog.fbtruetype fbtruetype/README.fbtruetype
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
@@ -94,6 +106,10 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/*
%changelog
+* Fri Aug 01 2003 Warly <warly@mandrakesoft.com> 2.0.1-1mdk
+- first vt is 0 and not 1 for bootsplash
+- add locale
+
* Thu Jul 31 2003 Warly <warly@mandrakesoft.com> 2.0.0-2mdk
- some images paths where wrong