aboutsummaryrefslogtreecommitdiffstats
path: root/USER/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'USER/Makefile.PL')
-rwxr-xr-xUSER/Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/USER/Makefile.PL b/USER/Makefile.PL
index 53d8cdf..309da57 100755
--- a/USER/Makefile.PL
+++ b/USER/Makefile.PL
@@ -1,4 +1,5 @@
use ExtUtils::MakeMaker;
+use Config;
$Verbose=1;
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
@@ -12,7 +13,7 @@ WriteMakefile(
'OBJECT' => 'USER.o', # link all the C files too
'LIBS' => $libs, # e.g., '-lm'
'DEFINE' => '-DPACKAGE_NAME=\"userdrake\"', # e.g., '-DHAVE_SOMETHING'
- 'INC' => "`pkg-config --cflags libuser`", # e.g., '-I. -I/usr/include/other'
+ 'INC' => "`pkg-config --cflags libuser` -I $Config{installvendorarch}", # e.g., '-I. -I/usr/include/other'
'XSPROTOARG' => '-noprototypes',
'TYPEMAPS' => [ '../perlobject.map' ],
);