summaryrefslogtreecommitdiffstats
path: root/t/02create_pkgs.t
diff options
context:
space:
mode:
Diffstat (limited to 't/02create_pkgs.t')
-rw-r--r--t/02create_pkgs.t3
1 files changed, 3 insertions, 0 deletions
diff --git a/t/02create_pkgs.t b/t/02create_pkgs.t
index 9fbf232c..84fac0af 100644
--- a/t/02create_pkgs.t
+++ b/t/02create_pkgs.t
@@ -2,6 +2,7 @@
use strict;
use lib '.', 't';
+use Config;
use helper;
use Test::More 'no_plan';
use Cwd;
@@ -40,6 +41,8 @@ foreach my $dir (grep { -d $_ } glob("data/SPECS/*")) {
}
foreach my $spec (glob("data/SPECS/*.spec")) {
+ warn "SKIPPING /rpm-query-in-scriptlet/" if $spec =~ /rpm-query-in-scriptlet/ && $Config{archname} =~ /bsd/;
+ next if $spec =~ /rpm-query-in-scriptlet/ && $Config{archname} =~ /bsd/;
my $name = rpmbuild($spec);
if ($name eq 'various') {