summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <tv@mageia.org>2013-02-25 17:56:45 +0000
committerThierry Vignaud <tv@mageia.org>2013-02-25 17:56:45 +0000
commitda59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549 (patch)
treee6faf4f4b1fbb72e4b915cc9ca0b64efd63f76ee /Makefile.PL
parentd44b92b31bbde9ee033a7049f36051f7ac2156a1 (diff)
downloadurpmi-da59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549.tar
urpmi-da59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549.tar.gz
urpmi-da59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549.tar.bz2
urpmi-da59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549.tar.xz
urpmi-da59df3a3e8f9d3e5eb6e0cd48f51f6cf1db8549.zip
(libscan) simplify
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5ed20f9c..b18cf035 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -29,8 +29,7 @@ package MY;
# Don't install gurpmi.pm if we don't install gui
sub libscan {
my ($self, $path) = @_;
- if (!$with_gui && $path =~ /gurpmi/) { return '' }
- return $path;
+ return !$with_gui && $path =~ /gurpmi/ ? '' : $path;
}
# Make proper sbin/man5/man8 dirs in blib