summaryrefslogtreecommitdiffstats
path: root/rpmconstant/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'rpmconstant/configure.ac')
-rw-r--r--rpmconstant/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/rpmconstant/configure.ac b/rpmconstant/configure.ac
new file mode 100644
index 0000000..e59bf9b
--- /dev/null
+++ b/rpmconstant/configure.ac
@@ -0,0 +1,29 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+# $Id$
+
+AC_PREREQ(2.59)
+AC_INIT(rpmconstant, 0.1.0, nanardon@zarb.org)
+AC_CONFIG_SRCDIR([rpmconstant.c])
+AM_INIT_AUTOMAKE(1.8)
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-lpopt':
+AC_CHECK_LIB([popt], [poptGetContext])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([string.h rpm/rpmlib.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+# Checks for library functions.
+
+AC_OUTPUT(Makefile)
+