summaryrefslogtreecommitdiffstats
path: root/RPM4/src/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <thierry.vignaud@gmail.com>2020-12-14 23:51:24 +0100
committerThierry Vignaud <thierry.vignaud@gmail.com>2020-12-14 23:57:24 +0100
commit2bb6cc6e2dae27f2827da52acd8395e334043596 (patch)
treefb40af39ad7f04ea45b28ae9d61bd1cb50dd7680 /RPM4/src/Makefile.PL
parent07561db81059e41d234799dca1c7beafb7203eea (diff)
downloadperl-RPM4-2bb6cc6e2dae27f2827da52acd8395e334043596.tar
perl-RPM4-2bb6cc6e2dae27f2827da52acd8395e334043596.tar.gz
perl-RPM4-2bb6cc6e2dae27f2827da52acd8395e334043596.tar.bz2
perl-RPM4-2bb6cc6e2dae27f2827da52acd8395e334043596.tar.xz
perl-RPM4-2bb6cc6e2dae27f2827da52acd8395e334043596.zip
Fix RPM4.xs/libperl.so mismatch on i586
It's OK on aarch64 & on x86_64 but it's broken on i586 eg: $ perl -MRPM4 RPM4.c: loadable library and perl binaries are mismatched (got handshake key 0x9100080, needed 0x9180080) Just build with the flags used to build perl itself in order to fix it
Diffstat (limited to 'RPM4/src/Makefile.PL')
-rw-r--r--RPM4/src/Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/RPM4/src/Makefile.PL b/RPM4/src/Makefile.PL
index 0f0d73c..f5f0440 100644
--- a/RPM4/src/Makefile.PL
+++ b/RPM4/src/Makefile.PL
@@ -1,6 +1,7 @@
# $Id$
# use 5.008;
+use Config;
use ExtUtils::MakeMaker;
use ExtUtils::PkgConfig;
use Getopt::Long;
@@ -100,6 +101,6 @@ WriteMakefile(
OBJECT => "RPM4.o $obj",
INC => "-I$rpmheaderlocation",
LIBS => [ $cfg{libs} . " -lrpmsign -lrpmbuild $ldd" ],
- CCFLAGS => "$cfg{cflags} -Wall $fl -DRPM$v",
+ CCFLAGS => "$cfg{cflags} -Wall $fl -DRPM$v $Config{ccflags}",
depend => { "RPM4.xs" => join(" ", @rpmconstantfiles) },
);