summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8fd2249..53473a9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -8,16 +8,17 @@ use ExtUtils::MakeMaker;
sub MY::postamble {
<<MAKE;
-.PHONY: ChangeLog
-
-ChangeLog:
+ChangeLog: \$(TO_INST_PM)
svn2cl -o ChangeLog || :
rm -f *.bak || :
+change_dist: ChangeLog tardist
+
MAKE
}
WriteMakefile(
NAME => 'MDV::Distribconf',
VERSION_FROM => 'lib/MDV/Distribconf.pm',
+ dist => { DIST_DEFAULT => 'change_dist' },
);