aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 00000000..171cd08f
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,35 @@
+use 5.006;
+use strict;
+use warnings FATAL => 'all';
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'AdminPanel',
+ AUTHOR => q{Angelo Naselli <anaselli@linux.it> - Matteo Pasotti <matteo.pasotti@gmail.com>},
+ VERSION_FROM => 'lib/AdminPanel/MainDisplay.pm',
+ ABSTRACT => 'AdminPanel contains a generic launcher application that can run perl modules or external programs using Suse YUI abstarction.',
+ LICENSE => 'GPL_2',
+ PL_FILES => {},
+ MIN_PERL_VERSION => 5.006,
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => 0,
+ },
+ BUILD_REQUIRES => {
+ 'Test::More' => 0,
+ },
+ PREREQ_PM => {
+ #'ABC' => 1.6,
+ #'Foo::Bar::Module' => 5.0401,
+ "Moose" => 0,
+ "Config::Hosts" => 0,
+ },
+ EXE_FILES => [ qw( scripts/adminMouse
+ scripts/adminService
+ scripts/adminUser
+ scripts/apanel.pl
+ scripts/hostmanager
+ scripts/mgaAddUser
+ ) ],
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'AdminPanel-*' },
+);