aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorAngelo Naselli <anaselli@linux.it>2014-01-27 18:20:30 +0100
committerAngelo Naselli <anaselli@linux.it>2014-01-27 18:20:30 +0100
commit1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b (patch)
tree1363e3d3bdcfa5b2ff3111a41b2c700a5a922140 /Makefile.PL
parentf519e47d15103514585a272c6308467ac41ce551 (diff)
downloadmanatools-1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b.tar
manatools-1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b.tar.gz
manatools-1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b.tar.bz2
manatools-1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b.tar.xz
manatools-1624ce382eb033c2cf3ef1fe6b9c41beb0b0a91b.zip
Project structure change
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 00000000..171cd08f
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,35 @@
+use 5.006;
+use strict;
+use warnings FATAL => 'all';
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'AdminPanel',
+ AUTHOR => q{Angelo Naselli <anaselli@linux.it> - Matteo Pasotti <matteo.pasotti@gmail.com>},
+ VERSION_FROM => 'lib/AdminPanel/MainDisplay.pm',
+ ABSTRACT => 'AdminPanel contains a generic launcher application that can run perl modules or external programs using Suse YUI abstarction.',
+ LICENSE => 'GPL_2',
+ PL_FILES => {},
+ MIN_PERL_VERSION => 5.006,
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => 0,
+ },
+ BUILD_REQUIRES => {
+ 'Test::More' => 0,
+ },
+ PREREQ_PM => {
+ #'ABC' => 1.6,
+ #'Foo::Bar::Module' => 5.0401,
+ "Moose" => 0,
+ "Config::Hosts" => 0,
+ },
+ EXE_FILES => [ qw( scripts/adminMouse
+ scripts/adminService
+ scripts/adminUser
+ scripts/apanel.pl
+ scripts/hostmanager
+ scripts/mgaAddUser
+ ) ],
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'AdminPanel-*' },
+);