aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorAngelo Naselli <anaselli@linux.it>2014-04-24 22:17:44 +0200
committerAngelo Naselli <anaselli@linux.it>2014-04-24 22:17:44 +0200
commita3cc10719525f6a88b802ea3fc65a94a5d998350 (patch)
tree196c923566fff36c5c4443ef5c05b421d242e5ba /Makefile.PL
parentc9a836d92e8463210a0ceb3e0254b463537732cd (diff)
downloadmanatools-a3cc10719525f6a88b802ea3fc65a94a5d998350.tar
manatools-a3cc10719525f6a88b802ea3fc65a94a5d998350.tar.gz
manatools-a3cc10719525f6a88b802ea3fc65a94a5d998350.tar.bz2
manatools-a3cc10719525f6a88b802ea3fc65a94a5d998350.tar.xz
manatools-a3cc10719525f6a88b802ea3fc65a94a5d998350.zip
Added password weakness checking
Improved icon and image installation and usage (File::ShareDir::Install)
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f74b4f40..ffbfea8c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -2,6 +2,10 @@ use 5.006;
use strict;
use warnings FATAL => 'all';
use ExtUtils::MakeMaker;
+use File::ShareDir::Install;
+
+install_share dist => 'share';
+
WriteMakefile(
NAME => 'AdminPanel',
@@ -28,6 +32,8 @@ WriteMakefile(
"Text::Iconv" => 0,
"Date::Simple" => 0,
"File::HomeDir" => 0,
+ "File::ShareDir" => 0,
+ "Data::Password::Meter" => 0,
},
EXE_FILES => [ qw( scripts/adminMouse
scripts/adminService
@@ -40,3 +46,6 @@ WriteMakefile(
dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
clean => { FILES => 'AdminPanel-*' },
);
+
+package MY;
+use File::ShareDir::Install 'postamble';