aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorAngelo Naselli <anaselli@linux.it>2015-04-22 13:40:11 +0200
committerAngelo Naselli <anaselli@linux.it>2015-04-22 13:40:11 +0200
commit3520dca63d26723c61f3426ea4ea32605873cb57 (patch)
tree94ee0f50d9f58687f5783b409d6c700131546be4 /Makefile.PL
parent501009369ecfe788943dc1100501ec126c92417d (diff)
downloadmanatools-3520dca63d26723c61f3426ea4ea32605873cb57.tar
manatools-3520dca63d26723c61f3426ea4ea32605873cb57.tar.gz
manatools-3520dca63d26723c61f3426ea4ea32605873cb57.tar.bz2
manatools-3520dca63d26723c61f3426ea4ea32605873cb57.tar.xz
manatools-3520dca63d26723c61f3426ea4ea32605873cb57.zip
Fixed some headers, and changed targets to clean_locales and
install_locales instead of mo
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4dc3a7a9..d133a89e 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -117,20 +117,23 @@ GOALS = $(PGOAL).pot $(MOFILES)
locales: $(GOALS)
-install_mo: locales
+install_locales: locales
for l in $(LANGS); do \
install -d $(localedir)/$$l/LC_MESSAGES; \
install -m 644 $$l.mo $(localedir)/$$l/LC_MESSAGES/$(PGOAL).mo; \
done
-clean_mo:
- rm -f *~ *.[oas] *.mo TAGS POTFILES.in
+clean_locales:
+ rm -f po/*~ po/*.[oas] po/*.mo
%.mo: %.po
msgfmt --check -o $@ $<
$(PGOAL).pot: $(PL_FILES)
xgettext --from-code=UTF-8 --language=Perl -D ./ -o po/$@ \
+ --msgid-bugs-address="https://bugs.mageia.org/" \
+ --package-name=$(NAME) --package-version=$(VERSION) \
+ --copyright-holder="Angelo Naselli - Matteo Pasotti" \
--keyword=N --keyword=N_ --keyword=P \
$(PL_FILES)