aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2007-06-29 13:30:24 +0000
committerPascal Rigaux <pixel@mandriva.com>2007-06-29 13:30:24 +0000
commit6cbb51a6bf5f4ccfc3388ce39a3bbd5b14a91217 (patch)
tree7e5723a41d828799e9759547bfd72c0133ba297f /configure.ac
downloadmga-youri-submit-upstream.tar
mga-youri-submit-upstream.tar.gz
mga-youri-submit-upstream.tar.bz2
mga-youri-submit-upstream.tar.xz
mga-youri-submit-upstream.zip
prepare mergeupstream
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..0170347
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+AC_PREREQ(2.59)
+AC_INIT([youri-submit], [0.10])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+
+AC_PATH_PROG([PERL],[perl])
+if test -z $PERL; then
+ AC_MSG_ERROR([perl not found, aborting])
+fi
+
+AC_PATH_PROG([POD2MAN],[pod2man])
+if test -z $POD2MAN; then
+ AC_MSG_ERROR([pod2man not found, aborting])
+fi
+
+perllibdir=$datadir/youri/lib
+AC_SUBST(perllibdir)
+
+AC_CONFIG_FILES([Makefile bin/Makefile lib/Makefile etc/Makefile t/Makefile])
+AC_OUTPUT