aboutsummaryrefslogtreecommitdiffstats
path: root/CatDap.spec
diff options
context:
space:
mode:
authorRomain d'Alverny <rda@mageia.org>2011-01-07 23:15:42 +0000
committerRomain d'Alverny <rda@mageia.org>2011-01-07 23:15:42 +0000
commitf07e6b1361c4817980888496a14b9b8d1fd5578d (patch)
treef66b7834e012d816aeabaf0f68cf14192c9d844b /CatDap.spec
parent1808659fc6d7d51ab2069a9b7868e2b8dfdf1f5d (diff)
downloadidentity-f07e6b1361c4817980888496a14b9b8d1fd5578d.tar
identity-f07e6b1361c4817980888496a14b9b8d1fd5578d.tar.gz
identity-f07e6b1361c4817980888496a14b9b8d1fd5578d.tar.bz2
identity-f07e6b1361c4817980888496a14b9b8d1fd5578d.tar.xz
identity-f07e6b1361c4817980888496a14b9b8d1fd5578d.zip
commit spec file from Maarten Vanraes
Diffstat (limited to 'CatDap.spec')
-rw-r--r--CatDap.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/CatDap.spec b/CatDap.spec
new file mode 100644
index 0000000..032c805
--- /dev/null
+++ b/CatDap.spec
@@ -0,0 +1,67 @@
+%define upstream_name CatDap
+%define upstream_version 0.0.1-r200
+
+Name: perl-%{upstream_name}
+Version: %perl_convert_version %{upstream_version}
+Release: %mkrel 1
+Summary: Web Based LDAP Administration Program
+License: GPL+ or Artistic
+Group: System/Configuration/Other
+Url: http://www.mageia.org/wiki/doku.php?id=web:identity
+Source0: %{upstream_name}-%{upstream_version}.tar.bz2
+BuildRequires: perl(Module::Install)
+BuildRequires: perl(Module::Install::Catalyst)
+BuildRequires: perl(Catalyst::Plugin::ConfigLoader)
+BuildRequires: perl(Catalyst::Plugin::Static::Simple)
+BuildRequires: perl(Catalyst::Plugin::I18N)
+BuildRequires: perl(Catalyst::Plugin::Unicode::Encoding)
+BuildRequires: perl(Catalyst::Plugin::Authentication)
+BuildRequires: perl(Catalyst::Plugin::Authentication::Store::LDAP)
+BuildRequires: perl(Catalyst::Plugin::Authorization::Roles)
+BuildRequires: perl(Catalyst::Plugin::Captcha)
+BuildRequires: perl(Catalyst::Plugin::Session::Store::File)
+BuildRequires: perl(Catalyst::Plugin::Session::State::Cookie)
+BuildRequires: perl(Catalyst::Action::RenderView)
+BuildRequires: perl(Catalyst::View::TT)
+BuildRequires: perl(Catalyst::View::Email)
+BuildRequires: perl(Catalyst::Model::LDAP::FromAuthentication)
+BuildRequires: perl(Crypt::CBC)
+BuildRequires: perl(Email::Valid)
+BuildRequires: perl(Data::UUID)
+BuildRequires: perl(Config::General)
+BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}
+
+%description
+CatDap is a combination of system-administrator and end-user web
+interface, designed to handle LDAP based setups.
+It fetches the schema to handle any kind of case, but is made to work
+with groups to give various access.
+
+%prep
+%setup -q -n %{upstream_name}-%{upstream_version}
+
+%build
+%{__perl} Makefile.PL INSTALLDIRS=vendor
+%make
+
+%check
+#make test
+
+%install
+rm -rf %buildroot
+%makeinstall_std
+
+%clean
+rm -rf %buildroot
+
+%files
+%defattr(-,root,root)
+%doc Changes
+%doc README
+%doc catdap.yml
+%{_mandir}/man1/*
+%{_mandir}/man3/*
+%{perl_vendorlib}/CatDap.pm
+%{perl_vendorlib}/CatDap
+%{_bindir}/catdap_*.pl