aboutsummaryrefslogtreecommitdiffstats
path: root/USER/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'USER/Makefile.PL')
-rw-r--r--USER/Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/USER/Makefile.PL b/USER/Makefile.PL
new file mode 100644
index 0000000..fd29950
--- /dev/null
+++ b/USER/Makefile.PL
@@ -0,0 +1,15 @@
+use ExtUtils::MakeMaker;
+$Verbose=1;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'USER',
+# 'OPTIMIZE' => '-O3 -fomit-frame-pointer -fno-exceptions -fno-rtti -pipe -s -ffast-math -fexpensive-optimizations',
+ 'VERSION_FROM' => 'USER.pm',
+ 'OBJECT' => 'USER.o', # link all the C files too
+ 'LIBS' => ['-llibuser -lgmodule-2.0 -lglib-2.0 -lcrypt'], # e.g., '-lm'
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => '-I/usr/include/libuser -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include', # e.g., '-I. -I/usr/include/other'
+ 'XSPROTOARG' => '-noprototypes',
+ 'TYPEMAPS' => ['../perlobject.map' ],
+);