aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py91
1 files changed, 91 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9226073
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,91 @@
+from distutils.core import setup
+import sys, os
+
+LOCALE_DIR= '/usr/share/locale'
+
+locales = []
+if os.path.exists('po/locale'):
+ for lang in os.listdir('po/locale'):
+ locales.append(os.path.join(lang, 'LC_MESSAGES'))
+
+if sys.platform == 'win32':
+ import py2exe
+ LOCALE_DIR = 'locale'
+ manifest = """
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
+ <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
+ <security>
+ <requestedPrivileges>
+ <requestedExecutionLevel
+ level="requireAdministrator"
+ uiAccess="False"/>
+ </requestedPrivileges>
+ </security>
+ </trustInfo>
+ <dependency>
+ <dependentAssembly>
+ <assemblyIdentity type="win32" name="Microsoft.VC90.CRT" version="9.0.21022.8" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
+ </dependentAssembly>
+ </dependency>
+</assembly>
+"""
+
+
+ setup(
+ name = 'usbdumper',
+ version = '3.6.4',
+ packages = ['liveusb'],
+ scripts = ['usbdumper'],
+ license = 'GNU General Public License (GPL)',
+ url = 'http://git.mandriva.com/?p=projects/mandriva-seed.git',
+ description = 'This tool dumps hybrid ISO on USB stick',
+ long_description = 'usbdumper is a cross-platform tool for easily dump hybrid ISO on USB flash drives',
+ platforms = ['Windows'],
+ maintainer = 'Aurelien Lefebvre',
+ maintainer_email = 'alefebvre@mandriva.com',
+ windows = [
+ {
+ "script" : "usbdumper",
+ "other_resources": [(24,1,manifest)],
+ #"icon_resources" : [(0, "data/mdv.ico")],
+ }
+ ],
+ options={
+ "py2exe" : {
+ #"includes" : ["sip", "PyQt4._qt"],
+ "includes" : ["sip"],
+ 'bundle_files': 1,
+ }
+ },
+ zipfile=None,
+ data_files = [
+ "LICENSE.txt",
+ ("tools", [
+ "tools/dd.exe",
+ "tools/dd.exe.manifest",
+ ],)
+ ] + [(os.path.join(LOCALE_DIR, locale),
+ [os.path.join('po', 'locale', locale, 'liveusb-creator.mo')])
+ for locale in locales]
+ )
+else:
+ setup(
+ name = 'usbdumper',
+ version = '3.6.4',
+ packages = ['liveusb'],
+ scripts = ['usbdumper'],
+ license = 'GNU General Public License (GPL)',
+ url = 'http://git.mandriva.com/?p=projects/mandriva-seed.git',
+ description = 'This tool dumps hybrid ISO on USB stick',
+ long_description = 'usbdumper is a cross-platform tool for easily dump hybrid ISO on USB flash drives',
+ platforms = ['Linux'],
+ maintainer = 'Aurelien Lefebvre',
+ maintainer_email = 'alefebvre@mandriva.com',
+ data_files = [("/usr/share/applications",["data/liveusb-creator.desktop"]),
+ ('/usr/share/pixmaps',["data/fedorausb.png"]),
+ ] + [(os.path.join(LOCALE_DIR, locale),
+ [os.path.join('po', 'locale', locale, 'liveusb-creator.mo')])
+ for locale in locales]
+ )
+