aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py19
1 files changed, 8 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 9226073..1703039 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ if sys.platform == 'win32':
setup(
name = 'usbdumper',
- version = '3.6.4',
+ version = '3.7.0',
packages = ['liveusb'],
scripts = ['usbdumper'],
license = 'GNU General Public License (GPL)',
@@ -42,8 +42,8 @@ if sys.platform == 'win32':
description = 'This tool dumps hybrid ISO on USB stick',
long_description = 'usbdumper is a cross-platform tool for easily dump hybrid ISO on USB flash drives',
platforms = ['Windows'],
- maintainer = 'Aurelien Lefebvre',
- maintainer_email = 'alefebvre@mandriva.com',
+ maintainer = 'Yves Brungard',
+ maintainer_email = 'yves.brungard_mageia@gadz.org',
windows = [
{
"script" : "usbdumper",
@@ -56,15 +56,12 @@ if sys.platform == 'win32':
#"includes" : ["sip", "PyQt4._qt"],
"includes" : ["sip"],
'bundle_files': 1,
+ "dll_excludes": ["mswsock.dll", "MSWSOCK.dll"],
}
},
zipfile=None,
data_files = [
"LICENSE.txt",
- ("tools", [
- "tools/dd.exe",
- "tools/dd.exe.manifest",
- ],)
] + [(os.path.join(LOCALE_DIR, locale),
[os.path.join('po', 'locale', locale, 'liveusb-creator.mo')])
for locale in locales]
@@ -72,16 +69,16 @@ if sys.platform == 'win32':
else:
setup(
name = 'usbdumper',
- version = '3.6.4',
+ version = '3.7.0',
packages = ['liveusb'],
scripts = ['usbdumper'],
license = 'GNU General Public License (GPL)',
- url = 'http://git.mandriva.com/?p=projects/mandriva-seed.git',
+ url = 'http://svnweb.mageia.org/soft/usbdumper',
description = 'This tool dumps hybrid ISO on USB stick',
long_description = 'usbdumper is a cross-platform tool for easily dump hybrid ISO on USB flash drives',
platforms = ['Linux'],
- maintainer = 'Aurelien Lefebvre',
- maintainer_email = 'alefebvre@mandriva.com',
+ maintainer = 'Yves Brungard',
+ maintainer_email = 'yves.brungard_mageia@gadz.org',
data_files = [("/usr/share/applications",["data/liveusb-creator.desktop"]),
('/usr/share/pixmaps',["data/fedorausb.png"]),
] + [(os.path.join(LOCALE_DIR, locale),