aboutsummaryrefslogtreecommitdiffstats
path: root/grpmi/curl_download/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'grpmi/curl_download/Makefile.PL')
-rw-r--r--grpmi/curl_download/Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/grpmi/curl_download/Makefile.PL b/grpmi/curl_download/Makefile.PL
new file mode 100644
index 00000000..47bc8ffc
--- /dev/null
+++ b/grpmi/curl_download/Makefile.PL
@@ -0,0 +1,23 @@
+use ExtUtils::MakeMaker;
+use Config;
+
+
+system("curl-config --libs 2>/dev/null 1>/dev/null") == 0
+ or
+ die_('CURL development environment seems to be missing (curl-config command reports an error)');
+
+
+WriteMakefile(
+ 'NAME' => 'curl_download',
+ 'LIBS' => [ chomp_(`curl-config --libs`) ],
+ 'VERSION_FROM' => 'curl_download.pm', # finds VERSION
+ 'OBJECT' => 'curl_download.o',
+ 'INC' => '-I.',
+ 'OPTIMIZE' => '-O2 -Wall -Werror',
+ 'MAKEFILE' => 'Makefile_c',
+);
+
+
+
+sub chomp_ { my @l = map { my $l = $_; chomp $l; $l } @_; wantarray ? @l : $l[0] }
+sub die_ { die "\n **ERROR**: @_\n\n" }