summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4a3bc858..8a3207ab 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -29,6 +29,13 @@ if ($with_gui) {
# And now, add some functionality to MakeMaker.
package MY;
+# Don't install gurpmi.pm if we don't install gui
+sub libscan {
+ my ($self, $path) = @_;
+ if (!$with_gui && $path =~ /gurpmi/) { return '' }
+ return $path;
+}
+
# Make proper sbin/man5/man8 dirs in blib
sub top_targets {
my $inherited = shift->SUPER::top_targets(@_);