summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2006-03-13 14:03:33 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2006-03-13 14:03:33 +0000
commiteb231750a5407050b49bea981221f4686fb9f407 (patch)
treecd90578c37e599726584d483e563ea752ff5668a /Makefile.PL
parent70c0f849ce703544e0632806d340e8883f98f1d1 (diff)
downloadurpmi-eb231750a5407050b49bea981221f4686fb9f407.tar
urpmi-eb231750a5407050b49bea981221f4686fb9f407.tar.gz
urpmi-eb231750a5407050b49bea981221f4686fb9f407.tar.bz2
urpmi-eb231750a5407050b49bea981221f4686fb9f407.tar.xz
urpmi-eb231750a5407050b49bea981221f4686fb9f407.zip
Don't install gurpmi.pm if we don't install GUI utils
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4a3bc858..8a3207ab 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -29,6 +29,13 @@ if ($with_gui) {
# And now, add some functionality to MakeMaker.
package MY;
+# Don't install gurpmi.pm if we don't install gui
+sub libscan {
+ my ($self, $path) = @_;
+ if (!$with_gui && $path =~ /gurpmi/) { return '' }
+ return $path;
+}
+
# Make proper sbin/man5/man8 dirs in blib
sub top_targets {
my $inherited = shift->SUPER::top_targets(@_);