summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 34b0432a..5f4f5087 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -81,9 +81,9 @@ installconfigfiles:
installstatedir:
install -d \$(LOCALSTATEDIR)/urpmi
- install -d \$(LOCALSTATEDIR)/urpmi/partial
- install -d \$(LOCALSTATEDIR)/urpmi/headers
- install -d \$(LOCALSTATEDIR)/urpmi/rpms
+ install -d \$(DESTDIR)/var/cache/urpmi/partial
+ install -d \$(DESTDIR)/var/cache/urpmi/headers
+ install -d \$(DESTDIR)/var/cache/urpmi/rpms
installgurpmi2: pure_install
ln -s -f consolehelper \$(DESTINSTALLSCRIPT)/gurpmi2
@@ -132,7 +132,7 @@ WriteMakefile(
},
EXE_FILES => [ @bin_scripts, @sbin_scripts ],
PMLIBDIRS => [ qw(urpm) ],
- DIR => $with_po ? [ 'po' ] : undef,
+ $with_po ? (DIR => [ 'po' ]) : (),
MAN1PODS => {
map {
my $targ = $_;