summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2005-11-25 14:08:17 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2005-11-25 14:08:17 +0000
commit24bd671fcbeda98d9ade49c24c69df60aacf2c42 (patch)
tree15f6c04ed004a904f3bb64a1ff02675d861b4166 /Makefile.PL
parent4d94ca97d65d61c28d6314cdd48f6e74a775e33f (diff)
downloadurpmi-24bd671fcbeda98d9ade49c24c69df60aacf2c42.tar
urpmi-24bd671fcbeda98d9ade49c24c69df60aacf2c42.tar.gz
urpmi-24bd671fcbeda98d9ade49c24c69df60aacf2c42.tar.bz2
urpmi-24bd671fcbeda98d9ade49c24c69df60aacf2c42.tar.xz
urpmi-24bd671fcbeda98d9ade49c24c69df60aacf2c42.zip
Fix mistake in dir names
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 34b0432a..5f4f5087 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -81,9 +81,9 @@ installconfigfiles:
installstatedir:
install -d \$(LOCALSTATEDIR)/urpmi
- install -d \$(LOCALSTATEDIR)/urpmi/partial
- install -d \$(LOCALSTATEDIR)/urpmi/headers
- install -d \$(LOCALSTATEDIR)/urpmi/rpms
+ install -d \$(DESTDIR)/var/cache/urpmi/partial
+ install -d \$(DESTDIR)/var/cache/urpmi/headers
+ install -d \$(DESTDIR)/var/cache/urpmi/rpms
installgurpmi2: pure_install
ln -s -f consolehelper \$(DESTINSTALLSCRIPT)/gurpmi2
@@ -132,7 +132,7 @@ WriteMakefile(
},
EXE_FILES => [ @bin_scripts, @sbin_scripts ],
PMLIBDIRS => [ qw(urpm) ],
- DIR => $with_po ? [ 'po' ] : undef,
+ $with_po ? (DIR => [ 'po' ]) : (),
MAN1PODS => {
map {
my $targ = $_;