summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5cf5506d..21ee3442 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -80,8 +80,11 @@ sub manifypods {
#- TODO repartition of man pages in sections by pod2man is incorrect
#- TODO as more languages are added adapt the following quick hack
if ($with_po) {
- $inherited =~ s/(INST_MAN(\d)DIR\)\/)\bfr\b/$1..\/fr\/man$2/g;
- $inherited =~ s/\t\$/\t\$(NOECHO) \$(MKPATH) \$(INST_MAN8DIR)\/..\/fr\/man8\n$&/;
+ my $lang = 'fr';
+ # make fr man directory
+ $inherited =~ s/\t\$/\t\$(NOECHO) \$(MKPATH) \$(INST_MAN8DIR)\/..\/$lang\/man8\n$&/;
+ # install fr manpages in correct path
+ $inherited =~ s{(INST_MAN(\d)DIR\)/)$lang(\/\S+)(\.$lang)?\.\2}{$1../$lang/man$2$3.$2}g;
}
$inherited;
}