summaryrefslogtreecommitdiffstats
path: root/t/02create_pkgs.t
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2008-02-04 16:02:21 +0000
committerPascal Rigaux <pixel@mandriva.com>2008-02-04 16:02:21 +0000
commitaaa119565207a6ee2f5cddb2730e51e2af49a21e (patch)
tree95bd916d91daca8840042d349642ec951af12c4f /t/02create_pkgs.t
parent9497ba7914e95a48b80af8270284371bf30e9a80 (diff)
downloadurpmi-aaa119565207a6ee2f5cddb2730e51e2af49a21e.tar
urpmi-aaa119565207a6ee2f5cddb2730e51e2af49a21e.tar.gz
urpmi-aaa119565207a6ee2f5cddb2730e51e2af49a21e.tar.bz2
urpmi-aaa119565207a6ee2f5cddb2730e51e2af49a21e.tar.xz
urpmi-aaa119565207a6ee2f5cddb2730e51e2af49a21e.zip
do set _tmppath
Diffstat (limited to 't/02create_pkgs.t')
-rw-r--r--t/02create_pkgs.t4
1 files changed, 3 insertions, 1 deletions
diff --git a/t/02create_pkgs.t b/t/02create_pkgs.t
index f4c9941a..d9411b3c 100644
--- a/t/02create_pkgs.t
+++ b/t/02create_pkgs.t
@@ -4,6 +4,7 @@ use strict;
use lib '.', 't';
use helper;
use Test::More 'no_plan';
+use Cwd;
chdir 't' if -d 't';
system('rm -rf tmp media');
@@ -61,7 +62,8 @@ sub genhdlist_std {
sub rpmbuild {
my ($spec, $o_medium_name) = @_;
- system_("rpmbuild --quiet --define '_topdir tmp' -bb --clean --nodeps $spec");
+ my $dir = getcwd();
+ system_("rpmbuild --quiet --define '_topdir $dir/tmp' --define '_tmppath $dir/tmp' -bb --clean --nodeps $spec");
my ($name) = $spec =~ m!([^/]*)\.spec$!;