summaryrefslogtreecommitdiffstats
path: root/t/02create_pkgs.t
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2006-11-30 17:57:43 +0000
committerPascal Rigaux <pixel@mandriva.com>2006-11-30 17:57:43 +0000
commit62c1446f09cc16428431510218e5e4f1e06271f3 (patch)
treea0a3601c5138ac60d2a92752b196ab6bea6c4008 /t/02create_pkgs.t
parent981c22ad5c1752789bbccd1e09302c2123d930d2 (diff)
downloadurpmi-62c1446f09cc16428431510218e5e4f1e06271f3.tar
urpmi-62c1446f09cc16428431510218e5e4f1e06271f3.tar.gz
urpmi-62c1446f09cc16428431510218e5e4f1e06271f3.tar.bz2
urpmi-62c1446f09cc16428431510218e5e4f1e06271f3.tar.xz
urpmi-62c1446f09cc16428431510218e5e4f1e06271f3.zip
more tests, clean some others, enhance helper.pm
Diffstat (limited to 't/02create_pkgs.t')
-rw-r--r--t/02create_pkgs.t8
1 files changed, 8 insertions, 0 deletions
diff --git a/t/02create_pkgs.t b/t/02create_pkgs.t
index 8a716226..ff6dabba 100644
--- a/t/02create_pkgs.t
+++ b/t/02create_pkgs.t
@@ -15,6 +15,14 @@ foreach my $spec (glob("SPECS/*.spec")) {
my ($name) = $spec =~ m!([^/]*)\.spec$!;
mkdir "media/$name";
system_("mv RPMS/*/*.rpm media/$name");
+
+ if ($name eq 'various') {
+ system_("cp -r media/various media/various_nohdlist");
+ system_("cp -r media/various media/various_no_subdir");
+ system_("genhdlist --dest media/various_no_subdir");
+ }
+
+ system_("genhdlist --subdir media/$name/media_info media/$name");
}
sub system_ {