summaryrefslogtreecommitdiffstats
path: root/t/02create_pkgs.t
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2006-11-30 13:28:03 +0000
committerPascal Rigaux <pixel@mandriva.com>2006-11-30 13:28:03 +0000
commit37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe (patch)
tree9847ca49d51ce41e951fcabcd0ed6344a3e5009a /t/02create_pkgs.t
parente15d45cca3d34d223927cf37f497de3a9703fb78 (diff)
downloadurpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.gz
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.bz2
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.xz
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.zip
using --urpmi-root, create some tests using urpmi.addmedia, urpmi, urpme
one drawback of the superuser--*.t is the need to be root (the rpmlib needs it to install in a root partition), so for now "make test" tests *.t but superuser--*.t are skipped. Then as root, run "sudo make test TEST_FILES='t/superuser--*.t'"
Diffstat (limited to 't/02create_pkgs.t')
-rw-r--r--t/02create_pkgs.t24
1 files changed, 24 insertions, 0 deletions
diff --git a/t/02create_pkgs.t b/t/02create_pkgs.t
new file mode 100644
index 00000000..8a716226
--- /dev/null
+++ b/t/02create_pkgs.t
@@ -0,0 +1,24 @@
+#!/usr/bin/perl
+
+use strict;
+use warnings;
+use Test::More 'no_plan';
+
+chdir 't' if -d 't';
+system('rm -rf BUILD RPMS media');
+for (qw(media BUILD RPMS RPMS/noarch)) {
+ mkdir $_;
+}
+# locally build a test rpms
+foreach my $spec (glob("SPECS/*.spec")) {
+ system_("rpmbuild --quiet --define '_topdir .' -bb --clean $spec");
+ my ($name) = $spec =~ m!([^/]*)\.spec$!;
+ mkdir "media/$name";
+ system_("mv RPMS/*/*.rpm media/$name");
+}
+
+sub system_ {
+ my ($cmd) = @_;
+ system($cmd);
+ ok($? == 0, $cmd);
+}