summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2006-03-20 16:10:40 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2006-03-20 16:10:40 +0000
commit9578db97227ea459ca5d033f08f71562ed303f4c (patch)
tree8c8712d13ae9b77ba24baec790124a4187fbd09e /Makefile.PL
parente6d88767662a14b4f11147a8a7842c7890daa3ad (diff)
downloadurpmi-9578db97227ea459ca5d033f08f71562ed303f4c.tar
urpmi-9578db97227ea459ca5d033f08f71562ed303f4c.tar.gz
urpmi-9578db97227ea459ca5d033f08f71562ed303f4c.tar.bz2
urpmi-9578db97227ea459ca5d033f08f71562ed303f4c.tar.xz
urpmi-9578db97227ea459ca5d033f08f71562ed303f4c.zip
More ugly makefile hacks
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index c41c9f03..5cf5506d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -79,7 +79,10 @@ sub manifypods {
my $inherited = shift->SUPER::manifypods(@_);
#- TODO repartition of man pages in sections by pod2man is incorrect
#- TODO as more languages are added adapt the following quick hack
- $with_po and $inherited =~ s/\t\$/\t\$(NOECHO) \$(MKPATH) \$(INST_MAN8DIR)\/fr\n$&/;
+ if ($with_po) {
+ $inherited =~ s/(INST_MAN(\d)DIR\)\/)\bfr\b/$1..\/fr\/man$2/g;
+ $inherited =~ s/\t\$/\t\$(NOECHO) \$(MKPATH) \$(INST_MAN8DIR)\/..\/fr\/man8\n$&/;
+ }
$inherited;
}
@@ -90,6 +93,8 @@ sub postamble {
installpo:
\$(MAKE) -C po install
+ \$(NOECHO) \$(MOD_INSTALL) \\
+ \$(INST_MAN8DIR)\/..\/fr \$(DESTDIR)/usr/share/man/fr
installconfigfiles:
install -d \$(SYSCONFDIR)/urpmi