aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2002-08-05 19:04:10 +0000
committerPascal Rigaux <pixel@mandriva.com>2002-08-05 19:04:10 +0000
commit9be8d3b3407562628b07f0b2c27b673ef208f225 (patch)
tree90b9744ee4fc8b953fc120ff38671d44c35aa35f /Makefile.PL
parenteac9649e7ca04a812481abb66c922c2345ef9207 (diff)
downloadrpmtools-9be8d3b3407562628b07f0b2c27b673ef208f225.tar
rpmtools-9be8d3b3407562628b07f0b2c27b673ef208f225.tar.gz
rpmtools-9be8d3b3407562628b07f0b2c27b673ef208f225.tar.bz2
rpmtools-9be8d3b3407562628b07f0b2c27b673ef208f225.tar.xz
rpmtools-9be8d3b3407562628b07f0b2c27b673ef208f225.zip
- remove obsolete stuff4.5.2
- move packdrake.pm in its own directory to make MakeMaker happy
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL29
1 files changed, 0 insertions, 29 deletions
diff --git a/Makefile.PL b/Makefile.PL
deleted file mode 100644
index 308216a..0000000
--- a/Makefile.PL
+++ /dev/null
@@ -1,29 +0,0 @@
-use ExtUtils::MakeMaker;
-# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-# the contents of the Makefile that is written.
-
-# old version that works actually somewhat well...
-sub version_compare {
- my ($a, $b) = @_;
- local $_;
-
- while ($a || $b) {
- my ($sb, $sa) = map { $1 if $a =~ /^\W*\d/ ? s/^\W*0*(\d+)// : s/^\W*(\D*)// } ($b, $a);
- $_ = ($sa =~ /^\d/ || $sb =~ /^\d/) && length($sa) <=> length($sb) || $sa cmp $sb and return $_ || 0;
- $sa eq '' && $sb eq '' and return $a cmp $b || 0;
- }
- 0;
-}
-
-my $libs = ' -lrpm -lrpmio ' . (version_compare(qx(rpm -q --qf %{VERSION} rpm), "4.0.3") >= 0 && "-lrpmdb ") . '-lpopt -lz -lbz2';
-
-WriteMakefile(
- 'NAME' => 'rpmtools',
- 'OPTIMIZE' => '-O3 -fomit-frame-pointer -fno-exceptions -fno-rtti -pipe -s -ffast-math -fexpensive-optimizations',
- 'MAKEFILE' => 'Makefile_core',
- 'OBJECT' => 'rpmtools.o',
- 'VERSION_FROM' => 'rpmtools.pm',
- 'LIBS' => [$libs], # e.g., '-lm'
- 'INC' => '-I/usr/include/rpm', # e.g., '-I/usr/include/other'
-);
-