aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.com>2006-06-12 16:25:18 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.com>2006-06-12 16:25:18 +0000
commit4423f97602bc478ee1fb3e6ad786f0d27ef114c7 (patch)
treee57bb05ea024d3805c8608f9346a1740f4e074d3 /Makefile.PL
parent9107fb60aa78fd7796cad742915782f01f402ed3 (diff)
downloadrpmtools-4423f97602bc478ee1fb3e6ad786f0d27ef114c7.tar
rpmtools-4423f97602bc478ee1fb3e6ad786f0d27ef114c7.tar.gz
rpmtools-4423f97602bc478ee1fb3e6ad786f0d27ef114c7.tar.bz2
rpmtools-4423f97602bc478ee1fb3e6ad786f0d27ef114c7.tar.xz
rpmtools-4423f97602bc478ee1fb3e6ad786f0d27ef114c7.zip
Make the makefile svn-compliant, and regenerate the changelog
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL17
1 files changed, 10 insertions, 7 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 7a99e8f..3a2fe55 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -15,8 +15,15 @@ my $spec;
or die "no version found\n";
warn "building rpmtools version v$rpmtools_version\n";
-my $tag_version = "v$rpmtools_version";
-$tag_version =~ s/\./_/g;
+# to generate the ChangeLog depending on the checkout layout
+my $commonusername = "../common/";
+-d $commonusername or do {
+ $commonusername = "../../common/";
+ -d $commonusername or do {
+ $commonusername = "../../../common/";
+ -d $commonusername or $commonusername = "";
+ };
+};
sub MY::postamble {
<<MAKEMAKEFILE;
@@ -35,15 +42,11 @@ cleanc:
rm -rf *.cz test
ChangeLog:
- cvs2cl -W 400 -I ChangeLog --accum -U ../common/username
+ LC_ALL=C svn2cl --accum --strip-prefix=soft/rpm/rpmtools/trunk --authors ${commonusername}username.xml
rm -f *.bak
rpm: dist
rpm --define "_sourcedir `pwd`" -ba --clean --rmsource rpmtools.spec
-
-tag:
- cvs tag $tag_version
-
MAKEMAKEFILE
}