aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 16 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e968e2..d745843 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,14 +7,11 @@ pkg_gdata = \
macros \
rpmrc
-pkg_macrosd_tmp = \
- build.macros
-
pkg_data_in = $(pkg_gdata:=.in)
-pkg_macrosd_in = $(pkg_macrosd_tmp:=.in)
+pkg_macrosd = macros.gnome
-pkg_macrosd = $(pkg_macrosd_tmp)
+pkg_macrosd_in = $(pkg_macrosd:=.in)
pkg_gconfig = \
platform \
@@ -28,10 +25,7 @@ pkg_scripts = \
fix-libtool-from-moving-options-after-libs \
fix-libtool-ltmain-from-overlinking \
force-as-needed-for-shared-lib-in-libtool \
- git-repository--after-tarball \
- git-repository--apply-patch \
http.req \
- info-file.req \
multiarch.req \
perl_base.req \
perl.prov \
@@ -48,15 +42,19 @@ pkg_scripts_in = $(pkg_gscripts:=.in)
pkg_attr_defs = \
devel.attr \
- info.attr \
multiarch.attr \
perl_base.attr \
perl_from_meta.attr \
php.attr
-redhat_defs = \
+redhat_scripts = \
brp-mangle-shebangs
+redhat_hardened = \
+ redhat-hardened-cc1 \
+ redhat-hardened-clang.cfg \
+ redhat-hardened-ld
+
BUILT_SOURCES = macros-perarch make_arch_macrosfiles.sh rpmgenplatform
foobar_pkglibdir = @RPMVENDORDIR@
@@ -84,7 +82,8 @@ EXTRA_DIST = \
$(pkg_attr_defs) \
$(pkg_scripts) \
$(pkg_scripts_in) \
- $(redhat_defs) \
+ $(redhat_scripts) \
+ $(redhat_hardened) \
macros-perarch.in make_arch_macrosfiles.sh.in \
rpmgenplatform.in rpmrc.in \
rpm-spec-mode.el \
@@ -117,7 +116,7 @@ platform: rpmgenplatform Makefile
platform32: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU32) > $@
-install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_macrosd_tmp)
+install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_macrosd)
if ONLY_RPMRC
echo "not installing per-arch macros which are already in rpmrc and standard rpm per-arch macros"
else
@@ -133,7 +132,10 @@ endif
for i in $(pkg_attr_defs); do \
$(install_sh_DATA) $${i} $(DESTDIR)$(RPMLIBDIR)/fileattrs/$${i}; \
done
- for i in $(redhat_defs); do \
+ for i in $(redhat_scripts); do \
+ $(install_sh_SCRIPT) $${i} $(DESTDIR)$(RPMLIBDIR)/redhat/$${i}; \
+ done
+ for i in $(redhat_hardened); do \
$(install_sh_DATA) $${i} $(DESTDIR)$(RPMLIBDIR)/redhat/$${i}; \
done
if RPMPLATFORM
@@ -149,5 +151,5 @@ test: $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)
sh tests.sh
CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)\
- macros-perarch $(pkg_macrosd_tmp) \
+ macros-perarch $(pkg_macrosd) \
make_arch_macrosfiles.sh