aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThierry Vignaud <thierry.vignaud@gmail.com>2019-08-29 21:04:45 +0200
committerThierry Vignaud <thierry.vignaud@gmail.com>2019-08-29 21:33:13 +0200
commit84e99b656252de1ea34098445193b14b1a72f969 (patch)
tree5ec118859ac1e94add31e037a3bd807d475d856a /Makefile.am
parent5f81cbd8ababaf8b50bfe680ddb1268b2a35ce0b (diff)
downloadrpm-setup-84e99b656252de1ea34098445193b14b1a72f969.tar
rpm-setup-84e99b656252de1ea34098445193b14b1a72f969.tar.gz
rpm-setup-84e99b656252de1ea34098445193b14b1a72f969.tar.bz2
rpm-setup-84e99b656252de1ea34098445193b14b1a72f969.tar.xz
rpm-setup-84e99b656252de1ea34098445193b14b1a72f969.zip
move macros files into /usr/lib/rpm/macros.d
move them from /etc/rpm/macros.d into /usr/lib/rpm/macros.d thus fixing most failures with rpm's testsuite (related to not being able to disable debuginfo)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 619d682..1ff4b4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,14 +7,14 @@ pkg_gdata = \
macros \
rpmrc
-pkg_sysconf_macros_tmp = \
+pkg_macrosd_tmp = \
build.macros
pkg_data_in = $(pkg_gdata:=.in)
-pkg_sysconf_macros_in = $(pkg_sysconf_macros_tmp:=.in)
+pkg_macrosd_in = $(pkg_macrosd_tmp:=.in)
-pkg_sysconf_macros = $(pkg_sysconf_macros_tmp)
+pkg_macrosd = $(pkg_macrosd_tmp)
pkg_gconfig = \
platform \
@@ -80,7 +80,7 @@ foobar_pkglib_SCRIPTS = \
EXTRA_DIST = \
$(pkg_data_in) \
- $(pkg_sysconf_macros_in) \
+ $(pkg_macrosd_in) \
$(pkg_attr_defs) \
$(pkg_scripts) \
$(pkg_scripts_in) \
@@ -116,7 +116,7 @@ platform: rpmgenplatform Makefile
platform32: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU32) > $@
-install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_sysconf_macros_tmp)
+install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_macrosd_tmp)
if ONLY_RPMRC
echo "not installing per-arch macros which are already in rpmrc and standard rpm per-arch macros"
else
@@ -126,8 +126,8 @@ else
done
endif
[ -d $(DESTDIR)$(RPMSYSCONFDIR)/macros.d ] || $(mkinstalldirs) $(DESTDIR)$(RPMSYSCONFDIR)/macros.d
- for i in $(pkg_sysconf_macros); do \
- $(install_sh_DATA) $${i} $(DESTDIR)$(RPMSYSCONFDIR)/macros.d/$${i}; \
+ for i in $(pkg_macrosd); do \
+ $(install_sh_DATA) $${i} $(DESTDIR)$(RPMLIBDIR)/macros.d/$${i}; \
done
for i in $(pkg_attr_defs); do \
$(install_sh_DATA) $${i} $(DESTDIR)$(RPMLIBDIR)/fileattrs/$${i}; \
@@ -148,5 +148,5 @@ test: $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)
sh tests.sh
CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)\
- macros-perarch $(pkg_sysconf_macros_tmp) \
+ macros-perarch $(pkg_macrosd_tmp) \
make_arch_macrosfiles.sh