aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Thauvin <nanardon@mandriva.org>2007-06-17 16:23:03 +0000
committerOlivier Thauvin <nanardon@mandriva.org>2007-06-17 16:23:03 +0000
commit31d21f9ae093cd7f760464e523ca87f2bd24c6fa (patch)
tree7e4ef45a15a60657f5a5d1587d4f1da45e6c6ec3 /Makefile.am
parentb7098f1ef6f2dfbfaaf4eb3d98b1f09dd0446eb1 (diff)
downloadrpm-setup-31d21f9ae093cd7f760464e523ca87f2bd24c6fa.tar
rpm-setup-31d21f9ae093cd7f760464e523ca87f2bd24c6fa.tar.gz
rpm-setup-31d21f9ae093cd7f760464e523ca87f2bd24c6fa.tar.bz2
rpm-setup-31d21f9ae093cd7f760464e523ca87f2bd24c6fa.tar.xz
rpm-setup-31d21f9ae093cd7f760464e523ca87f2bd24c6fa.zip
- push into platform all compat arch
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 27e2844..5535346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,8 +14,6 @@ pkg_data_in = $(pkg_gdata:=.in)
pkg_gconfig = \
platform
-pkg_gconfig_in = $(pkg_gconfig:=.in)
-
pkg_scripts = \
brp-compress \
brp-strip \
@@ -40,7 +38,7 @@ pkg_gscripts = \
pkg_scripts_in = $(pkg_gscripts:=.in)
-BUILT_SOURCES = macros-perarch make_macrosfiles.sh
+BUILT_SOURCES = macros-perarch make_macrosfiles.sh genplatform
pkglibdir = @RPMVENDORDIR@
@@ -66,8 +64,8 @@ EXTRA_DIST = \
$(pkg_data_in) \
$(pkg_scripts) \
$(pkg_scripts_in) \
- $(pkg_gconfig_in) \
macros-perarch.in make_macrosfiles.sh.in \
+ genplatform.in \
rpm-spec-mode.el \
tests.sh tests/macros.sh
@@ -78,7 +76,8 @@ edit = sed \
-e 's,@RPMLIBDIR\@,$(RPMLIBDIR),g' \
-e 's,@RPMSYSCONFDIR\@,$(RPMSYSCONFDIR),g'\
-e 's,@RPMOS\@,$(RPMOS),g' \
- -e 's,@CANONTARGETCPU\@,$(CANONTARGETCPU),g'
+ -e 's,@CANONTARGETCPU\@,$(CANONTARGETCPU),g' \
+ -e 's,@RPMALLARCH\@,$(RPMALLARCH),g'
%: %.in Makefile
$(edit) $< > $@
@@ -87,6 +86,9 @@ edit = sed \
arch=`echo $@ | sed 's,\\.macros,,'`; \
sh ./make_macrosfiles.sh macros-perarch $$arch > $@
+platform: genplatform Makefile
+ perl genplatform $(CANONTARGETCPU) > $@
+
install-data-local: $(macrosfiles) $(pkg_gconfig)
for i in $(RPMALLARCH); do \
$(mkinstalldirs) $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS); \