aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJani Välimaa <wally@mageia.org>2019-12-26 20:49:34 +0200
committerJani Välimaa <wally@mageia.org>2019-12-26 20:49:34 +0200
commit1737e998727cfd711f051662d2dfdb07b35ca291 (patch)
tree4a2eb0e9afaed8051cb6ed05f076ac22d242905b /Makefile.am
parentb93059219fc9dbc5320232a85e13ec780664c171 (diff)
downloadrpm-setup-1737e998727cfd711f051662d2dfdb07b35ca291.tar
rpm-setup-1737e998727cfd711f051662d2dfdb07b35ca291.tar.gz
rpm-setup-1737e998727cfd711f051662d2dfdb07b35ca291.tar.bz2
rpm-setup-1737e998727cfd711f051662d2dfdb07b35ca291.tar.xz
rpm-setup-1737e998727cfd711f051662d2dfdb07b35ca291.zip
Simplify Makefile.am a bit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e968e2..455fc67 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,14 +7,11 @@ pkg_gdata = \
macros \
rpmrc
-pkg_macrosd_tmp = \
- build.macros
-
pkg_data_in = $(pkg_gdata:=.in)
-pkg_macrosd_in = $(pkg_macrosd_tmp:=.in)
+pkg_macrosd = build.macros
-pkg_macrosd = $(pkg_macrosd_tmp)
+pkg_macrosd_in = $(pkg_macrosd:=.in)
pkg_gconfig = \
platform \
@@ -117,7 +114,7 @@ platform: rpmgenplatform Makefile
platform32: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU32) > $@
-install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_macrosd_tmp)
+install-data-local: $(arch_macrosfiles) $(pkg_gconfig) $(pkg_macrosd)
if ONLY_RPMRC
echo "not installing per-arch macros which are already in rpmrc and standard rpm per-arch macros"
else
@@ -149,5 +146,5 @@ test: $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)
sh tests.sh
CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)\
- macros-perarch $(pkg_macrosd_tmp) \
+ macros-perarch $(pkg_macrosd) \
make_arch_macrosfiles.sh