aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérôme Quelin <jquelin@mandriva.org>2010-07-14 10:11:26 +0000
committerJérôme Quelin <jquelin@mandriva.org>2010-07-14 10:11:26 +0000
commitb8df618f7c537959d6765c08f4a48f535944a92b (patch)
tree53509b6a2cf02a00ffd4fd5d503896097ace8a10
parentaaa86c91b30c1d7ab16e4c974254315f4fe36017 (diff)
v1.105 - support to extract perl runtime requires from meta spec 21.105
-rw-r--r--NEWS3
-rw-r--r--configure.ac2
-rwxr-xr-xperl.req-from-meta4
3 files changed, 7 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 4d794bb..5e3e79b 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,6 @@
+Version 1.105 - 14 July 2010, by Jerome Quelin
+- support to extract perl runtime requires from meta spec 2
+
Version 1.104 - 27 April 2010, by Christophe Fergeau
- revert previous '-g' addition when stripping shared libraries since it
increases shared library sizes by 10 to 20% for no good reason
diff --git a/configure.ac b/configure.ac
index 1b0859e..36ac112 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@
# $Id$
AC_PREREQ(2.59)
-AC_INIT(rpm-mandriva-setup, 1.104, nanardon@mandriva.org)
+AC_INIT(rpm-mandriva-setup, 1.105, nanardon@mandriva.org)
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(1.9 -Wno-portability)
AC_CONFIG_SRCDIR
diff --git a/perl.req-from-meta b/perl.req-from-meta
index 5b612dd..4f921f6 100755
--- a/perl.req-from-meta
+++ b/perl.req-from-meta
@@ -18,7 +18,9 @@ my $meta = $path =~ /\.yml$/
: from_json( $data );
# dump the requires with their version
-my $requires = $meta->{requires};
+my $requires = $meta->{"meta-spec"}{version} >= 2
+ ? $meta->{prereqs}{runtime}{requires}
+ : $meta->{requires};
foreach my $module ( sort keys %$requires ) {
next if $module eq 'perl'; # minimum perl version
my $version = $requires->{$module};