aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8263fb7..7530397 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -11,6 +11,7 @@ our %CONFIGURE_REQUIRES = (
'ExtUtils::MakeMaker' => '6.64',
'ExtUtils::PkgConfig' => '1.00', # for finding rpm-devel
);
+my $is_debian = -f '/etc/debian_version';
# Writing a fake Makefile ensures that CPAN will pick up the correct
# dependencies and install them.
@@ -29,7 +30,8 @@ unless (eval "use ExtUtils::Depends '$CONFIGURE_REQUIRES{'ExtUtils::Depends'}';"
my %cfg;
unless (eval { %cfg = ExtUtils::PkgConfig->find("rpm >= $build_reqs{rpm}"); 1 })
{
- warn $@;
+ my $rpmdev_pkg = $is_debian ? "librpm-dev" : "rpm-devel";
+ warn "*** Ensure that $rpmdev_pkg is installed\n" . $@;
exit 0;
}