aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <thierry.vignaud@gmail.com>2017-11-01 01:11:09 +0100
committerThierry Vignaud <thierry.vignaud@gmail.com>2017-11-06 20:53:37 +0100
commit9051d2588fcaeccab68f5f74ae0e419fa21c9557 (patch)
tree60efff85eff973a8400034e7dd3f727fda00a58d /Makefile.PL
parent850a49881df49980431a56c38d539e7cd3f05577 (diff)
downloadperl-URPM-9051d2588fcaeccab68f5f74ae0e419fa21c9557.tar
perl-URPM-9051d2588fcaeccab68f5f74ae0e419fa21c9557.tar.gz
perl-URPM-9051d2588fcaeccab68f5f74ae0e419fa21c9557.tar.bz2
perl-URPM-9051d2588fcaeccab68f5f74ae0e419fa21c9557.tar.xz
perl-URPM-9051d2588fcaeccab68f5f74ae0e419fa21c9557.zip
advertize the proper pkg for most distros
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8263fb7..7530397 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -11,6 +11,7 @@ our %CONFIGURE_REQUIRES = (
'ExtUtils::MakeMaker' => '6.64',
'ExtUtils::PkgConfig' => '1.00', # for finding rpm-devel
);
+my $is_debian = -f '/etc/debian_version';
# Writing a fake Makefile ensures that CPAN will pick up the correct
# dependencies and install them.
@@ -29,7 +30,8 @@ unless (eval "use ExtUtils::Depends '$CONFIGURE_REQUIRES{'ExtUtils::Depends'}';"
my %cfg;
unless (eval { %cfg = ExtUtils::PkgConfig->find("rpm >= $build_reqs{rpm}"); 1 })
{
- warn $@;
+ my $rpmdev_pkg = $is_debian ? "librpm-dev" : "rpm-devel";
+ warn "*** Ensure that $rpmdev_pkg is installed\n" . $@;
exit 0;
}