aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 05a2b6a..90b00f3 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -27,13 +27,13 @@ $version =~ s/(-.*)|(\.DEVEL)//;
chomp $version;
$version =~ s/(RPM version )|(rpm \(RPM\) )//;
my $hversion = hexversion($version);
-$hversion ge hexversion("4.9") or die "Unable to build URPM with too old (or undetected) rpm version $version\n";
+$hversion ge hexversion("4.13") or die "Unable to build URPM with too old (or undetected) rpm version $version\n";
my @rpmflags;
my $ldflags = `pkg-config --libs rpm` . ' -lrpmbuild';
-if ($hversion ge hexversion("4.9.0") && $hversion lt hexversion("5.0")) {
- # rpm.org version 4.9.0
- push @rpmflags, "-DRPM490";
+if ($hversion ge hexversion("4.13.0") && $hversion lt hexversion("5.0")) {
+ # rpm.org version 4.13.0
+ push @rpmflags, "-DRPM4140";
}
my $ccflags = join(' ', '-Wall -Wextra -fno-strict-aliasing', @rpmflags);