aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 09d6704..0ce1e29 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -39,6 +39,7 @@ unless (eval { %cfg = ExtUtils::PkgConfig->find("rpm >= $build_reqs{rpm}"); 1 })
exit 0;
}
my @rpm_version = split /\./, $cfg{modversion};
+$cfg{modversion} =~ s/(?:-(?:beta|rc).*)?$//i;
open(my $FH, "> rpmversion.h") or die "Can't open rpmversion.h";
print $FH "/* File generated by Makefile.PL\n";
print $FH " */\n\n";