aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2004-04-02 14:02:41 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2004-04-02 14:02:41 +0000
commitef428d6cb520165ab91952852563f3a973dce2db (patch)
treebd86c53ff18a30c440e25386e5570b980fb64204 /Makefile.PL
parentbde52864b5d3c577498865f2af89769b026917e3 (diff)
downloadperl-URPM-ef428d6cb520165ab91952852563f3a973dce2db.tar
perl-URPM-ef428d6cb520165ab91952852563f3a973dce2db.tar.gz
perl-URPM-ef428d6cb520165ab91952852563f3a973dce2db.tar.bz2
perl-URPM-ef428d6cb520165ab91952852563f3a973dce2db.tar.xz
perl-URPM-ef428d6cb520165ab91952852563f3a973dce2db.zip
Add some API documentation for the URPM module.
Plus, some minor nits in auxiliary files.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 85a5890..72bf988 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,9 +1,8 @@
use ExtUtils::MakeMaker;
-# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-# the contents of the Makefile that is written.
-my $version = `rpm -q --qf '%{VERSION}\n' rpm`;
-$version =~ /^(?:[4-9]|\d{2})/ or die "unable to build URPM with too old (or undetected) rpm version $version";
+my $version = `rpm -q --qf '%{VERSION}' rpm`;
+$version =~ /^(?:[4-9]|\d{2})/
+ or die "Unable to build URPM with too old (or undetected) rpm version $version\n";
#- search for correct libraries to use (above 4.0.3 is right).
my $libs = $version =~ /^4\.0(?:\.[012])?$/ ?