aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorFrancois Pons <fpons@mandriva.com>2002-05-31 10:21:16 +0000
committerFrancois Pons <fpons@mandriva.com>2002-05-31 10:21:16 +0000
commit548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e (patch)
tree472f9f9ecacbf8996f1ee28a9c70a465d16c8819 /Makefile.PL
parent9de7e3110b4c105da73d051e26c239e22b276020 (diff)
downloadperl-URPM-548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e.tar
perl-URPM-548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e.tar.gz
perl-URPM-548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e.tar.bz2
perl-URPM-548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e.tar.xz
perl-URPM-548baa81a0a4e3db8120e9d0e33cf75c1bf77a5e.zip
initial revision.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..eba032e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,13 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+
+WriteMakefile(
+ 'NAME' => 'URPM',
+ 'OPTIMIZE' => '-O3 -fomit-frame-pointer -fno-exceptions -fno-rtti -pipe -s -ffast-math -fexpensive-optimizations',
+ 'MAKEFILE' => 'Makefile',
+ 'OBJECT' => 'URPM.o',
+ 'VERSION_FROM' => 'URPM.pm',
+ 'LIBS' => ['-lrpm -lrpmio -lrpmdb -lpopt -lz -lbz2'], # e.g., '-lm'
+ 'INC' => '-I/usr/include/rpm', # e.g., '-I/usr/include/other'
+);