summaryrefslogtreecommitdiffstats
path: root/RPM4/src/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'RPM4/src/Makefile.PL')
-rw-r--r--RPM4/src/Makefile.PL11
1 files changed, 1 insertions, 10 deletions
diff --git a/RPM4/src/Makefile.PL b/RPM4/src/Makefile.PL
index 6dbf55c..009c45c 100644
--- a/RPM4/src/Makefile.PL
+++ b/RPM4/src/Makefile.PL
@@ -33,20 +33,11 @@ print $FH ' * $Id$' . "\n";
print $FH " */\n\n";
print $FH "#ifndef RPMVERSION_H\n#define RPMVERSION_H\n\n";
foreach (qw(
- 4.9.0
- 4.9.1
- 4.9.1.1
- 4.9.1.2
- 4.10.0
- 4.11.0
- 4.11.1
- 4.11.2
- 4.11.3
- 4.12.0
4.12.90
4.15.0
)) {
my $v = $_;
+ $rpmv < $v and last;
$v =~ s/\./_/g;
print $FH "#define RPM$v\n";
$rpmv =~ /^\Q$_/ and last;