summaryrefslogtreecommitdiffstats
path: root/RPM4/src/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'RPM4/src/Makefile.PL')
-rw-r--r--RPM4/src/Makefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/RPM4/src/Makefile.PL b/RPM4/src/Makefile.PL
index 0295f36..fd81e27 100644
--- a/RPM4/src/Makefile.PL
+++ b/RPM4/src/Makefile.PL
@@ -83,12 +83,14 @@ RPMCONSTTBL
$first . $second;
}
+my $v = $rpmv;
+$v =~ s/\./_/g;
WriteMakefile(
NAME => 'RPM4',
VERSION_FROM => '../lib/RPM4.pm',
OBJECT => "RPM4.o $obj",
INC => "-I$rpmheaderlocation",
LIBS => [ $cfg{libs} . " -lrpmsign -lrpmbuild $ldd" ],
- CCFLAGS => "$cfg{cflags} -Wall $fl",
+ CCFLAGS => "$cfg{cflags} -Wall $fl -DRPM$v",
depend => { "RPM4.xs" => join(" ", @rpmconstantfiles) },
);