summaryrefslogtreecommitdiffstats
path: root/rootfiles.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rootfiles.spec')
-rw-r--r--rootfiles.spec78
1 files changed, 49 insertions, 29 deletions
diff --git a/rootfiles.spec b/rootfiles.spec
index b6bc86e..d868522 100644
--- a/rootfiles.spec
+++ b/rootfiles.spec
@@ -1,16 +1,17 @@
-%define version 7.2
-%define release 2mdk
-%define name rootfiles
-
-Summary: The basic required files for the root user's directory.
-Name: %{name}
-Version: %{version}
-Release: %{release}
-Copyright: public domain
-Group: System/Base
-Source: %{name}-%{version}.tar.bz2
-BuildRoot: %{_tmppath}/%{name}-root
-BuildArchitectures: noarch
+# MODIFY IN THE CVS !!
+Summary: The basic required files for the root user's directory
+Name: rootfiles
+# MODIFY IN THE CVS !!
+Version: 8.0
+Release: 1mdk
+License: Public domain
+Group: System/Base
+Packager: David BAUDENS <baudens@mandrakesoft.com>
+
+Source: %name.tar.bz2
+
+BuildRoot: %_tmppath/%name-%version-%release-root
+BuildArchitectures: noarch
%description
The rootfiles package contains basic required files that are placed
@@ -19,38 +20,57 @@ as the files found in the etcskel package, which are placed in regular
users' home directories.
%prep
-%setup -q
+%setup -q -n %name
%install
rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/root
-make install RPM_BUILD_ROOT=$RPM_BUILD_ROOT/
+install -d %buildroot/root
+make install RPM_BUILD_ROOT=%buildroot
%clean
rm -rf $RPM_BUILD_ROOT
-#%pre
-## we used to put .Xclients in this package -- back it up if it's been
-## customized
-#cd /root
-#if [ -f .Xclients -a -x /bin/awk ]; then
-# m=`md5sum .Xclients | awk '{ print $1 }'`
-# if [ $m != "506b9496f2853fc9fee6c6b1c5f3ee48" ]; then
-# mv .Xclients .Xclients.rpmsave
-# fi
-#fi
+%pre
+# we used to put .Xclients in this package -- back it up if it's been
+# customized
+cd /root
+if [ -f .Xclients -a -x /bin/awk ]; then
+ m=`md5sum .Xclients | awk '{ print $1 }'`
+ if [ $m != "506b9496f2853fc9fee6c6b1c5f3ee48" ]; then
+ mv .Xclients .Xclients.rpmsave
+ fi
+fi
%files
%defattr(-,root,root)
%doc ChangeLog
-%config /root/.[A-z]*
-%config /root/Desktop/
+%config(noreplace) /root/.Xdefaults
+%config(noreplace) /root/.bash_logout
+%config(noreplace) /root/.bash_profile
+%config(noreplace) /root/.bashrc
+%config(noreplace) /root/.cshrc
+%dir /root/.kde
+%config(noreplace) /root/.kde/*
+%config(noreplace) /root/.kderc
+%dir /root/.netscape
+%config(noreplace) /root/.netscape/*
+%config(noreplace) /root/.tcshrc
+%config(noreplace) /root/.vimrc
+%dir /root/Desktop
+/root/Desktop/*
%attr(0700,root,root) /root/tmp/
%changelog
-* Tue Mar 13 2001 Pixel <pixel@mandrakesoft.com> 7.2-2mdk
+* Tue Mar 13 2001 Pixel <pixel@mandrakesoft.com> 8.0-1mdk
- vimrc: remove "Default tab for 4" (set ts=4)
+* Thu Jan 18 2001 David BAUDENS <baudens@mandrakesoft.com> 7.3-1mdk
+- Fix build on PPC
+- Spec clean up
+
+* Wed Nov 08 2000 David BAUDENS <baudens@mandrakesoft.com> 7.2-2mdk
+- Use config(noreplace)
+
* Mon Oct 9 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 7.2-1mdk
- rebuild for 7.2