summaryrefslogtreecommitdiffstats
path: root/rootfiles.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rootfiles.spec')
-rw-r--r--rootfiles.spec167
1 files changed, 167 insertions, 0 deletions
diff --git a/rootfiles.spec b/rootfiles.spec
new file mode 100644
index 0000000..300d7c3
--- /dev/null
+++ b/rootfiles.spec
@@ -0,0 +1,167 @@
+%define version 7.0
+%define release 3mdk
+%define name rootfiles
+
+Summary: The basic required files for the root user's directory.
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Copyright: public domain
+Group: System Environment/Base
+Source: %{name}-%{version}.tar.bz2
+BuildRoot: /var/tmp/%{name}-root
+BuildArchitectures: noarch
+
+%description
+The rootfiles package contains basic required files that are placed
+in the root user's account. These files are basically the same
+as the files found in the etcskel package, which are placed in regular
+users' home directories.
+
+%prep
+%setup -q
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/root
+make install RPM_BUILD_ROOT=$RPM_BUILD_ROOT/
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%pre
+# we used to put .Xclients in this package -- back it up if it's been
+# customized
+cd /root
+if [ -f .Xclients -a -x /bin/awk ]; then
+ m=`md5sum .Xclients | awk '{ print $1 }'`
+ if [ $m != "506b9496f2853fc9fee6c6b1c5f3ee48" ]; then
+ mv .Xclients .Xclients.rpmsave
+ fi
+fi
+
+%files
+%defattr(-,root,root)
+%config /root/.[A-z]*
+%config /root/Desktop/
+%attr(0700,root,root) /root/tmp/
+
+%changelog
+
+* Wed Dec 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- fix vimrc with vim-minimal.
+
+* Tue Dec 21 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- put ~/tmp as 700.
+
+* Sat Dec 18 1999 Pixel <pixel@mandrakesoft.com>
+- added .netscape/(cache|archive)
+
+* Thu Dec 16 1999 François PONS <fpons@mandrakesoft.com>
+- removed Cd-Rom.kdelnk and floppy.kdelnk, since handled by DrakX.
+
+* Thu Dec 16 1999 Pixel <pixel@mandrakesoft.com>
+- moved Templates from Desktop to .kde
+- better .emacs (especially gnu-emacs)
+
+* Fri Dec 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- Syn Desktop.
+
+* Thu Dec 02 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- Alias df to -x supermount.
+
+* Wed Dec 01 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- Remove the export XAUTHORITY for root.
+
+* Sat Nov 27 1999 Pixel <pixel@linux-mandrake.com>
+- .vimrc: `syntax on' only if vim-common is there
+
+* Mon Nov 15 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- Add hwiz.kdelnk in Autostart of kde package.
+
+* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- Fix .emacs (<c> Chmouel All right reserved).
+
+* Mon Oct 25 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+- fix stupid path in .bashrc (thanks john).
+
+* Tue Sep 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Add Desktop directory.
+- Kde in English.
+
+* Tue Sep 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Insert kde configuration and Desktop of kde directly here.
+
+* Fri Aug 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Fix typo.
+
+* Fri Aug 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Bind Windows key to (K)menu.
+
+* Sun Aug 8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- zshrc: by defaut we launch the completion machine.
+
+* Thu Aug 05 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Fix typo in .vimrc.
+
+* Mon Aug 2 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Syn on only with enhanced vim.
+- Add statusbar for vim
+- New alias in bashrc.
+
+* Tue Jun 15 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Tmp for root.
+
+* Tue May 18 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Fix locales bug rapport by Jean Michel <jmdault@netrevolution.com>
+
+
+* Wed May 12 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Security path for root.
+- Suppr work now for root.
+
+* Tue May 11 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- a /sbin and /usr/sbin for root even for telnet.
+
+* Sun May 09 1999 Gaël Duval <gael@linux-mandrake.com>
+
+- Added .kderc for root
+- changed the version number (5.2->6.0)
+
+* Sun May 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
+
+- Mandrake adaptations.
+
+* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
+- auto rebuild in the new build environment (release 5)
+
+* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
+- add %clean (#719)
+
+* Tue Dec 29 1998 Cristian Gafton <gafton@redhat.com>
+- build for 6.0
+
+* Wed Oct 9 1998 Bill Nottingham <notting@redhat.com>
+- remove /root from %files (it's in filesystem)
+
+* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
+- portability fix for .cshrc (problem #235)
+- change version to be same as release.
+
+* Tue Sep 09 1997 Erik Troan <ewt@redhat.com>
+- made a noarch package
+
+* Thu Mar 20 1997 Erik Troan <ewt@redhat.com>
+- Removed .Xclients and .Xsession from package, added %pre to back up old
+ .Xclients if necessary.